SR sent and service accept back but UE still out of services

Hi Experts.

I faced an issue today on SA, my DUT was sending SR for n66 followed by service accept back to UE from the Network but on UE UI it was out of service.

However same cell was working for a reference device, reference device was getting PDU session est. Accept and 5 G icon was there on the UE.

Can someone please help me to figure out the actual cause for this?
Thanks in advance experts

What was your RSRP and RSRQ when this happened?

It was between -70 to -80 dBm.

Then you must take a UE trace to see what is going on.
Or network trace if possible.

UE trace you mean QXDM logs?

Yes, exactly.

Yes, I took that and I was observing that it was getting PSI true in service accept.

I tried to look in Ll1 level as much but couldn’t figure out more.
However this I am seeing for particular sets of cells only.
May be some configuration issue from my device end.
Need to evaluate this further.

Please suggest if anything else I should do here…

Check internal traces, seems your UE going OOS.

Thanks @RFSpecialist , @ankgitm for the help!

It was actually carrier policy configuration file issue.

Today I modified and it worked!

Thanks for the support Experts!