Solution to signalling storm

Hi Experts,
Since the subscribers are given IMS APN as default, when subscribers requests to disable IMS operators are disabling it from HSS.
But it is not avoiding UE to try to make hundreds of register attempts that are released by HSS.
It is causing signalling storm.
Any opinion to solve this problem?


Try to disable VoLTE on mobile.

You can also send PDN Conn Rej for such requests to avoid signalling.

How about sending 503 service unavailable error code at SIP level with retry after header included?

When subscriber remove APN and its disabled in HSS, MME should reject Attach-Request since APN is not allowed any more.
If this process isn’t working, you may want to see why MME context isn’t updating after HSS updates records.

We cannot tell to disable to their APN on UE.
It is being done I think what about the ones that didn’t do it?
Any method that can avoid UE to initiate session with this IMS APN from radio?
Maybe to tweak a parameter to change sib2 messages?
Any idea?

It is needed to use a method so that UE should not try it again.
Maybe need to check specs with which cause you need to reject PDN for IMS.

You can change ACB parameters to limit the number of UEs from accessing mmtel services.
But it doesn’t work for registration.
How about sending an error code 403-forbidden?
For certain operators, UE won’t retry for IMS reg after receiving 403 forbidden until power cycle.

Have a look at this blog post, it might help in choosing correct reject cause:

It is not preventing UE to retry.
I see too many 403 for the same UE.