Issue with M2M simCard in private LTE

Hi guys!

I have an originally m2m simCard that has been reprogramed to work as general data access in private LTE.

What happens in field is that it works well at CPE, but doesn’t work at Phones.

It seems to be a Core issue…

Android and iOS devices try to attach, sometimes do attach, have IP assigned but drops when packaging.

It returns radio link failure due to some timeout.

Radio conditions are fine, CPE works just beside Phone.

1 Like

Is the m2m SIM card the same specs as a normal one?

1 Like

If there was a Sim card problem, attach would not be successful.

Getting successful attach suggest all fine from Core perspective, but this should be 100% all the times.

When attach isn’t successful what is the error message?

1 Like

From Core side the device established a Session with the Core, PGW sent the IP Address to the device.

But in the Tcpdump we could not see any packet going out eNodeB.

Seems that the eNodeB is not sending traffic at all from this device or packets are getting lost somewhere within eNodeB.

Core logs show UE Context Release due to Radio Connection Loss.

1 Like

Where did you take this tcpdump?

At PGW or SGW?

1 Like

Yes, it’s because of the attAch type, I guess.

Please check, weather Private Network Core support which attach types

Also try disable VoLTE from Android or iOS device, then try.

1 Like

This is good suggestion.

I was gonna also advise to look at the user profile and what’s its allowed and not allowed.

I haven’t worked with M2M so assuming they have some sort of special profiles in HLR different to standard Sim profile.

You can actually ask that from HLR guys and compare that.

That may provide you some idea what’s happening as well.

1 Like

Attach type “Combined” according to Core guys.

The SimCards were originally IoT sim, that have been reprogramed to work as normal access SIM.

I wonder if there is any flag or parameter at PGW that recognize it still as m2m and blocks data transfer.

That would explain why it attaches and drops - after 10 seconds (always 10 seconds).


I found something:

1 Like

I had a similar problem with a Private Network.

The issue was that the Private Network Core supported data only devices.

Voice devices fail to attach if the Private Core doesn’t support it (should have IMS Core associated, or “pretend” to support voice).

1 Like

Can you share PCAP?

1 Like

When you reprogram m2m SIM card to work in LTE, it should work provides operator gives valid IMSI APN.

Is the IMSI valid in the operator work?

I saw the pcap… Looks IMSI is valid and does EPS attach.

Where is it failing ?

1 Like

I don’t think this is not a sim card issue.

Yes, this is right.

I believe you are using a commercial UE, Android or iOS.

1 Like

After attach UE is releasing immediately with a cause radio connection with UE lost.

Check UE signal strength.

1 Like

Hi guys.

We used a valid SimCard - it attaches.

Samsung S10e phone, comercial phone - Ok.

RF conditions are not the best, but are Ok.

No interference arround, we are in a farm with no cells arround.

At MME logs we see UE Lost. It attaches, sets up PDP context and drops 10 seconds later.

But cause is radio, why do you search on Core for attach procedure?

Maybe RAN has a kind of Uplink radio link supervision that expires after 10 seconds.

It seems to me you are integrating a device so all kind of glitches can happen.

Update guys:

It’s very weird, but now - after some changes in Core - Phone connects!

But it does not navigate yet.

Userplane problem.

Phone goes to inactivity as no data.

Thank you all for your help!

It has Just worked now.

Some flag at Core that says Data Only.

  • QCI
  • Combined Attach
  • Roaming Scheme
1 Like