IPhone 12 attached to 4G but no IRAT to 3G

Dears,
I have an issue on IPhone 12 that when it was attached to 4G network it will not IRAT to 3G when it receiving or establishing a call.
Can one have an idea about this issue while the 4G data is working properly and this issue is occurred only on IPhone 12?

What about others handsets?
Is Samsung working fine?

This is weird.
This phone supports VoLTE, why does it has to do CSFB to 3G?
It is almost sure that is a case purchased in one country and used in another country so IMS profile is nok.
This is why VoLTE call does not setup properly.

1 Like

all handset are working properly except iphone 12

I dont know
to be noted that our eNode B is Alcatel.

Hello

You mean PS iRAT HO failed for iphone12, right?
How about inter-RAT event MR report by this UE?

1 Like

Hello,

the issue that once we insert the SIM card in the Iphone 12 we are unable to make calls or received.

Iphone 12 has some bugs that many people are complainig.
I met some cases that modern mobiles can not make or receive CSFB voice calls.
Some cause such as: new phones problem mismatch with network, capability message are too big and enb/RNC do not response, transmission issues…
So, it’s better to trace at enb, RNC and core to find root cause.

Thank you Hainm,
A trace ongoing with Nokia and Huawei support, I will keep you updated.

Hello dear, if this issue happens only with CSFB to 3G or 2G … you need to check the RRC complete msg size sent from UE since the i phone 12 is sending a big MSG size to eNB contains the “UE capability” in the RRC complete … thus the RNC will not process this request and the CSFB fails.

check for a parameter on the RNC side to let the eNB ( not to ask UE to send its capability ) and the issue will be solved

1 Like

I already met this problem, some phones such as iphone X, Samsung note 9,… can not do CSFB to 3G network.
After UE finish CSFB steps in 4G, UE initate RRC setup procedure in 3G, trace IMSI in RNC we can see message of UE.
Due to one parameter setting in RNC which require UE also send not only 3G-capability, but also 4G-capability. That’s why some advanced phone supporting alot of 4G functions will send a big-size RRC setup complete message. Normal phones often send RRC-complete of ~ 500 bytes while advanced phones may send 1600 bytes.
And RNC only process message < 1500 bytes, so these UE will be ignored and CSFB failed in 3G side.
To fix this problem we have 2 solution: disable parameter to request 3G-UE also send 4G-capability or upgrade RNC to version which can support > 1500 bytes of RRC complete messages.

Hello Dear,

Can you please provide the parameter that need to be adjust, our RNC is Alcatel.

Please share the parameter if possible.
For any vendor you have, than i will check if we have same one in Alcatel RNC.

I am sorry, I dont remember parameter name, just when I worked at HW.

1 Like

Hello dear,

Unfortunately I only have the parameter of Huawei RNC

But 90% the issue is related to msg size as mentioned

There must be a parameter in Alcatel RNC to the same work

Good luck

1 Like

Which parameters name? Mention please!