CLI Counters

Hello team,

do you know which is the structure/ command to get counters in E// CLI?

Thank you!

Hi, @Juan_Leon, in amos it is pget <object> <counter>:

pget cell rrc

in ENM CLI app:

cmedit get ERBS001 ENodeBFucntion.<pm>


I tried in ENM CLI but is not working

cmedit get node_id NRCellCU,pmDrbEstabAtt5qi
cmedit get node_id NRCellCU.(NRCellCUid==*,pmDrbEstabAtt5qi)
cmedit get node_id NRCellCU.

I tried these but not working.

can you try:
cmedit get node_id NRcellDU.(*) -t
tell me if it worked, then try with CU

Hi Jr!

not working as well, here is the error( I tried with DU and CU):

Error 1010 : An unknown attribute has been encountered; name pmEndcSetupUeSucc in the MO class NRCellDU. Verify valid attributes for the MO type in the latest models by executing the following cmedit describe command - “cmedit describe NRCellDU."/ "cmedit describe NRCellCU.

well, based on the error. The counter you are trying to query is for enodeb since its ENDC so it will not be available for gnodeb(NRCU-NRDU). I may be wrong so please take a look at the 4G side of the equation. And if not let me know so I can increase my knowledge.

We can use the same counter for LTE anchor cells and for NR cells


NR: pget NrcellCU= pmEndcSetupUeAtt|pmEndcSetupUeSucc$

but even using EUtranCellFDD.(pmEndcSetupUeSucc) -t also is not working.

ok got it. Just to be sure, Can you run the command just to see if the cells are up, no pm query, just to confirm youre able to hit the network element you want. If this is ok, maybe something wrong in the syntax of the query.

to print the cells I usually use :
cmedit get node_id EUtranCellFDD.(EUtranCellFDDid==*) -t -s

and for example, I tried with cmedit get nodeid EUtranCellFDD. -t and shows this error:

Error 9999 : Execution Error Execution Error - Querying for Performance Management (PM) attributes is only supported for CPP node types that support reading of PM counters as MO attributes

seems that the CNM is not working to read counter, do you have any other command with a counter that is working?

Try replacing the following with your rbss
cmedit get MeContext=ERBS001,ManagedElement=1;MeContext=ERBS002,ManagedElement=1 -

attr neType,userLabel

To get counters, don’t forget to add