2x2 MIMO no BLER, 4x4 30-90% BLER why?

Hi guys!

I am facing an issue and trying to resolve it before my R&D guys check it out.
I have a 4G cell in an anechoic room.
It is powered by a 4T4R 1800MHz Comba RRU.

Setup is working fine and I am doing the speed tests.
With a Galaxy S6 which is 2x2 capable only TPT is constant 140mbps with Iperf UDP pump.
With a Galaxy S10 which is 4x4 capable the TPT is unstable and varies between 30-300Mbps.
X-CAL shows that for the S6 bler is almost 0%, however for the S10 it is 30-90% and constantly changing.
I tried deactivating the PA for Ant Ports 2&4 and the TPT on the S10 became stable 186Mbps.
Tried deactivating the Ant2 PA only and the TPT started to vary between 150-300 mbps.
Checked all feeders on Ant1, one at a time, all gave stable 70mbps.
The Antenna array consists of 4 feeders going into 2 antennas, 60cm apart, both being cross polarized (2 feeders each, ±45 degrees).

What would cause this high BLER on 4x4 MIMO?
Anything else I should try?

Thank you!

256qam was not fully supported by my du load.

Tc can be closed

1 Like

Can you explain the solution more,