telecomHall.com | Hunter Blog | Tips Blog | Course Blog | Groups

Ericsson 2G CNAIv2 OSS Parameters Dump Parser


#43

@Mauricio_Santiago, you need 1.8+.

java version “1.8.0_171”
Java™ SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot™ 64-Bit Server VM (build 25.171-b11, mixed mode)

What you can do is:

  1. Download the JRE archive from http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

  2. I have highligted the file to download for 64 bit Linux.

  3. You can extract the file into your OSS account: tar -xvzf jre-8u171-linux-x64.tar.gz

  4. You should be able to run the parse like this: ~/jre1.8.0_171/bin/java -jar boda-ericssoncnaiparser.jar <dump_file or folder> <output_folder>

I hope you find this helpful.

Note: If you are wondering about the Oracle Binary Code Licence Agreement fr Java SE, it should not be an issue. Below is summary of what it says:

  • You can use it, but you can’t modify it
  • You agree not to sue Oracle if anything goes wrong
  • You can redistribute/publish it (so that you can sell products with Java embedded), but if you do, you agree to indemnify Oracle; so if someone sues you, you can’t drag Oracle into it.
  • You don’t have to pay anything if you are not using any of the commercial features which are not in this version of Java SE (http://www.oracle.com/technetwork/java/javase/terms/products/index.html)

#44

Hi Emmanuel, yes, with those tips I could make it work.
They have really done an excellent job with the parsers.
Very thankful.
Greetings.