telecomHall.com | Hunter Blog | Tips Blog | Course Blog | Groups

Ericsson 2G CNAIv2 OSS Parameters Dump Parser


#22

Dear Emmanuel,
Now it works.
Thank you very much.


#23

Hi Emmanuel, i’m having same issue as Daniel_V. parser finishing well but no CSV are created. the dump i have is one exported from OSS using cna_export OSS app. what can i do?


#24

Hello @Guillermo_Gustavo_Go,

Are you sure the dump is in the correct format?

It only work for command cnai_v2, not for command cna_export

CNAI version 2 command: > cnai export valid -i > YourFileName.txt


#25

these are my options

usage:
cna_export [AREA = user:area_name,]NW = network,
MSC = obj_file | all,MSC_REF = param_file | none | all,
[OUTERCELL = obj_file | all,OUTERCELL_REF = param_file | none | all,]
[BSC = obj_file | all,BSC_REF = param_file | none | all,
[PP = obj_file | all,PP_REF = param_file | none | all,]
[SITE = obj_file | all,SITE_REF = param_file | none | all,
[TG = obj_file | all,TG_REF = param_file | none | all,]]
[CELL = obj_file | all,CELL_REF = param_file | none | all,]]
OUTPUT = transfer_file_name[,MNCZEROEXPAND = yes | no ]

or

cna_export [AREA = user:area_name,]NW = network,
FCELL = obj_file | all,FCELL_REF = param_file | none | all,
OUTPUT = transfer_file_name

or

cna_export [AREA = user:area_name,]NW = network,
RNC = obj_file | all,RNC_REF = param_file | none | all,
[UCELL = obj_file | all,UCELL_REF = param_file | none | all,]
OUTPUT = transfer_file_name

Hint: With long command lines or for convenience, use either a script or source file.

don’t see CNAI version 2 command: > cnai export valid -i option


#26

Hi.
Even not “seing” the option, it is there.

In the command line, type:
cnai export valid -i > YourFileName.txt

And hit Enter

Check for the file created.

Please tell us if you have some error


#27

Perfect! sorry i didn’t know about the existence of this command and suspect spaces will not work.

many thanks for your quick response.

BR


#28

I am looking for a company that can recycle GSM 2G antennas for mobile telephony operators. We have a large inventory of 2G GSM antennas for recycling


#29

Hello Guys,

Yesterday I runned the parser successfully, but today I am getting the following error message:

“Parser has expired. Please request new version from www.telecomhall.net

I have already tried the most recent available version, with no success.

Is it possible to some of the developers of the tool remove this restriction, please?

Thanks,
Cesar


#30

@Cesar_Sanfelice,

The parser has been updated. Use the download link in the original post.

Emmanuel


#31

Thanks @Emmanuel, but with this new version I am getting the following error message, running the same command line:

Exception in thread “main” java.lang.NoClassDefFoundError: java/nio/file/Paths
at com.bodastage.boda_ericssoncnaiparser.BodaCNAIParser.processFileOrDirectory(BodaCNAIParser.java:211)
at com.bodastage.boda_ericssoncnaiparser.BodaCNAIParser.main(BodaCNAIParser.java:185)
Caused by: java.lang.ClassNotFoundException: java.nio.file.Paths
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
… 2 more

Could you help me?

Thanks,
Cesar


#32

@Cesar_Sanfelice,

Update your Java installation. https://java.com/en/download/


#33

Thanks Emmanuel,

I am running directly in the OSS Server without admin access, but saving an updated java version in my user´s home folder, it worked!

Thanks a lot,
Cesar


#34

Hi Emmanuel, Can you please provide eaw printout parsar for 2G.


#36

Hi @mithun, I will let you know when it has been uploaded.


#37

Hi Emmanuel,
can you share to us new version of the parser? (message : Parser has expired. Please request new version from www.telecomhall.net )


#38

@DSolo, the parser has been updated. The expiration has also be removed.


#39

Thank you very much. You save my job… :beers:


#40

Olá Cesar, como vai você?
Qual versão você usou Java para fazer isso a partir do OSS ???
Obrigado


#41

@Mauricio_Santiago

Checkout that article at the link below. It shows how you can install an up-to-date version of JDK/JRE in your OSS account.

http://www.oracle.com/technetwork/java/javase/install-linux-64-self-extracting-142068.html


#42

Hi Emmanuel, the java version on the server is this:
java version "1.6.0_115"
Java™ SE Runtime Environment (build 1.6.0_115-b12)
Java HotSpot™ Server VM (build 20.115-b12, mixed mode)

With what minimum version does the script work?
Thank you.